We're experiencing an issue with slow delivery times this morning. Our engineers are aware of the problem and working on a resolution.
Incident Report for MXGuardian
Resolved
The issue has been resolved and you should expect normal delivery times.
Posted Mar 28, 2024 - 16:09 UTC
Investigating
We are currently investigating this issue.
Posted Mar 28, 2024 - 15:26 UTC
This incident affected: Email Security Gateway (Inbound Queue).