Inbound messages delayed
Incident Report for MXGuardian
Postmortem

After further review, we discovered this event was triggered by a combination of 1) a spike in mail traffic at 9:00 EST and 2) a recent update to a module that decodes QR barcodes embedded in attached images and PDFs. We have rolled back the update until we can determine a workaround or a permanent fix. Thank you for your understanding.

Posted Mar 19, 2024 - 22:17 UTC

Resolved
We experienced an issue this morning around 9:00 EST (13:00 UTC) that caused messages to be delayed by up to 1 hour. We increased server capacity to handle the additional load, however, it took several hours to process the backlog of messages. Delivery times returned to normal at about 13:30 EST (18:30 UTC).
Posted Mar 19, 2024 - 18:00 UTC